Jetson上安装pytorchGPU版本

在Jetson上安装Pytorch的GPU版本,主要步骤包括确认JetPack版本、查找兼容的PyTorch版本、使用pip安装PyTorch,以及解决可能出现的安装问题

在Jetson上安装Pytorch的GPU版本,主要步骤包括确认JetPack版本、查找兼容的PyTorch版本、使用pip安装PyTorch,以及解决可能出现的安装问题

1. 查看JetPack版本

           cat /etc/nv_tegra_release
          得到JetPack版本后,在pytorch官网https://forums.developer.nvidia.com/t/ 上下载适合版本的pytorch

attachments-2024-01-GsaOrVbH65ae8a85ee13c.png

2. 安装pytorchGPU版

找到torch-1.7.0-cp36-cp36m-linux_aarch64.whl所在的目录

然后安装提示安装一系列依赖文件
attachments-2024-01-jIBYStxH65ae8b75cdf6c.png

3. 测试PytorchGPU版是否安装成功

4. 报错问题 ImportError: libopenblas.so.0缺少动态链接库

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python3.6/dist-packages/torch/__init__.py", line 190, in <module>
    from torch._C import *
ImportError: libopenblas.so.0: cannot open shared object file: No such file or directory
解决办法:sudo apt-get install libopenblas-dev
最后就可在Jetson设备上成功运行PytorchGPU版本


你可能感兴趣的文章

相关问题

0 条评论

请先 登录 后评论
LH
LH

14 篇文章

作家榜 »

  1. Panda-admin 37 文章
  2. 解弘艺 17 文章
  3. 高曾谊 16 文章
  4. 胡中天 14 文章
  5. 旺仔牛奶opo 14 文章
  6. LH 14 文章
  7. 罗柏荣 13 文章
  8. 林晨 12 文章